My F-Secure and Partner Portal services are currently down
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 30, 2023 - 12:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2023 - 17:50 UTC
Investigating
Currently some of our F-Secure services, access to Partner Portal and My F-Secure login is down: meaning no new accounts can be created, or new devices installed.

This however does not affect the protection of devices where F-Secure is already installed.

We are investigating this, and will give updates once we have identified the issue.
Posted Nov 27, 2023 - 14:11 UTC
This incident affected: F-Secure Global Operator Services (Operator Portal), F-Secure Operator Services EU (Avenue EU), F-Secure Operator Services APAC (Avenue APAC), F-Secure Operator Services NA (Avenue NA), and F-Secure Home Products (F-Secure SAFE, F-Secure IDP).