F-Secure ID Monitoring Internal Error

Incident Report for F-Secure services

Monitoring

The issue has been fixed and ID Monitoring is working normally again.
Posted Sep 26, 2025 - 09:12 UTC

Identified

We are currently having an issue with ID Monitoring in F-Secure Total.

The visible effect of this is that users will receive an internal error page when using ID Monitoring. The user cannot add a new monitoring entry/item.

We are working to fix the issue as soon as possible.

Note: There is no impact on any existing installations and security features.
Posted Sep 26, 2025 - 05:14 UTC
This incident affects: North America (Identity), Europe (Identity), and APAC (Identity).