F-Secure Partner Portal is down

Incident Report for F-Secure services

Resolved

We have successfully fixed the issue with Partner Portal. Login is working again as expected.
Posted Apr 29, 2025 - 13:45 UTC

Investigating

We would like to let you know that unfortunately Partner Portal is down at the moment. Logins for partners are not working. We are working to fix the issue as soon as possible.
Posted Apr 29, 2025 - 12:02 UTC
This incident affected: North America (Protection, Identity, Privacy, Customer Lifecycle Management), Europe (Protection, Identity, Privacy, Customer Lifecycle Management), and APAC (Protection, Identity, Privacy, Customer Lifecycle Management).