My F-Secure and Partner Portal are down

Incident Report for F-Secure services

Resolved

The issue has been fixed. Logins and installs work again as expected.
Posted Jul 01, 2025 - 11:28 UTC

Investigating

We are currently having an issue with My F-Secure and Partner Portal.
Users will not be able to access these sites to manage and install F-Secure products.
There is no impact on any existing installations and security features.
Posted Jul 01, 2025 - 08:38 UTC
This incident affected: North America (Customer Lifecycle Management), Europe (Customer Lifecycle Management), and APAC (Customer Lifecycle Management).