Degraded performance of F-Secure RDR
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 10:41 EET
Monitoring
The services are operating normally again. We continue to monitor the situation.
Posted Oct 19, 2020 - 11:25 EEST
Investigating
We are investigating a performance degradation of F-Secure Rapid Detection and Response.
Posted Oct 16, 2020 - 16:13 EEST
This incident affected: F-Secure Elements Endpoint Detection and Response (prev. RDR) (Portal, Detection Cloud).