Login and registration failure in My F-Secure
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Jul 08, 2022 - 12:13 EEST
Monitoring
Products affected by this incident were: F-Secure SAFE and TOTAL products

This morning, around 9:20 EET we noticed that login attempts to My F-Secure account and activation attempts of SAFE resulted failure.

When this was reported to us, we immediately started to investigate, and a fix was tested and approved at 11.30.

This issue did not effect the protection on devices.
Posted Jun 28, 2022 - 12:05 EEST
This incident affected: F-Secure Home Products (F-Secure SAFE, F-Secure IDP).