F-Secure Browsing Protection extension is currently not available for Mozilla Firefox
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted May 11, 2022 - 16:51 EEST
Update
The F-Secure Browsing Protection extension is available in Mozilla Firefox and can be activated again.

With the latest update of the extension all of the functionalities are available, with a minor limitation that the block pages are not displayed correctly. Instead Firefox will display an error that Secure Connection Failed. This does not affect the security of the computer.

We are working on restoring full functionality in Mozilla Firefox.
Posted Mar 29, 2022 - 11:04 EEST
Monitoring
The F-Secure Browsing Protection extension is available in Mozilla Firefox and can be activated again.

Currently, while pages are being blocked according to the settings, block pages are not displayed correctly. Instead Firefox will display an error that Secure Connection Failed.

Additionally, Safe Search mode used by Search engines (Google, Yahoo, DuckDuckGo and Bing) is not available when using F-Secure SAFE Family Rules, or Safe Search mode for Elements EPP products.

We are working on restoring full functionality in Mozilla Firefox.
Posted Mar 24, 2022 - 12:42 EET
Investigating
The Browsing Protection extension is currently not available for Mozilla Firefox.
The browser extension is a plug-in application that ensures your security while browsing.
For this reason, the Secure Browsing and Banking features do not fully work at the moment when using the Firefox browser on Windows devices.

We are working with Mozilla to solve this issue.

In the meanwhile, we recommend that you use either Microsoft Edge or Google Chrome browser until the issue has been fixed. If you have not yet installed the browser extensions for these browsers, you can find the instructions to install them here: https://help.f-secure.com/product.html#home/safe-windows/latest/en/task_C9E6D4FA2C7D4A0BA27CD8F1F7037308-safe-windows-latest-en
Posted Mar 18, 2022 - 16:23 EET
This incident affected: F-Secure Home Products (F-Secure SAFE).