Generic slowness and intermittent unavailability
Incident Report for F-Secure services
Resolved
Services are restored and responsive.
We apologize for any inconvenience caused.
Posted Nov 04, 2021 - 15:18 UTC
Investigating
We are investigating reports of slowness and intermittent unavailability of the following services:
Home users: My F-Secure
Operator partners: Avenue EU, Operator Portal

The issue may manifest itself with long wait times or time outs when performing actions or logging in to the service.
Installation or license activation may result in errors.
Endpoint protection is not compromised.
Posted Nov 04, 2021 - 08:05 UTC
This incident affected: F-Secure Global Operator Services (Operator Portal), F-Secure Operator Services EU (Avenue EU), and F-Secure Home Products (F-Secure SAFE).