Internet Explorer unable to load pages with Browsing Protection enabled
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 11:50 EET
Monitoring
A fix has been published and is being rolled out automatically.
The fix is included in the update:
F-Secure Ultralight Core (64-bit) 2020-11-05_01
F-Secure Ultralight Core (32-bit) 2020-11-05_01

We continue to monitor the situation.
Posted Nov 05, 2020 - 13:02 EET
Identified
We are currently testing a hotfix for affected versions and aim to publish it tomorrow (Thursday, 5th of November).
Affected versions remain (13.xx and 14.xx) of F-Secure Client Security and Server Security (14.xx).
Posted Nov 04, 2020 - 15:20 EET
Investigating
We are investigating an issue where Internet Explorer is unable to load pages when Browsing Protection is enabled.
This only affects older versions (13.xx and 14.xx) of Client Security and Server Security (14.xx). Version 15 is not affected.
Posted Nov 03, 2020 - 15:01 EET
This incident affected: Business Suite (Endpoints (Clients & Servers)).