Google blocks searches through the German VPN gateway
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted May 23, 2023 - 03:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2023 - 13:55 UTC
Identified
We have identified an issue whereby Google searches do not work for customers using our Germany VPN gateway.
We are working to get this resolved.
Posted May 01, 2023 - 02:32 UTC
This incident affected: F-Secure Home Products (F-Secure FREEDOME exit nodes).