Ultralight Core 2022-04-05_01 update causing blue screen in some Windows environments
Incident Report for F-Secure services
Resolved
An update F-Secure Ultralight Core 2022-04-05_01 was published on Tuesday 5th of April, 14:36 EET. It released a change that in some Windows clients caused a blue screen.

When this was reported to us we immediately started to investigate. A fix with update F-Secure Ultralight Core 2022-04-05_02 was release on same day at 20:18 EET.

This update should be downloaded and applied automatically, but in some rare cases manual work is required. In these cases following steps are needed:

1. Boot the system into safe mode
2. Rename fsulgk.sys file in the directory:
- Business Suite product: ...\F-Secure\\Ultralight\ulcore\1649156793
- Elements Endpoint Protection product: ...\F-Secure\PSB\Ultralight\ulcore\1649156793
3. Reboot the device normally and let the product update the components. New driver will be registered and enabled by the update.

Alternatively, removing the product in safe mode would help to avoid the blue screen. After re-installation the device would no longer face the blue screen with the latest Ultralight Core 2022-04-05_02 update.

If you need assistance, do not hesitate to contact WithSecure Support.
https://www.withsecure.com/gb-en/support

Products affected by this incident are: WithSecure and F-Secure Windows Endpoint Protection products
Posted Apr 13, 2022 - 16:23 EEST
Monitoring
An update F-Secure Ultralight Core 2022-04-05_01 was published on Tuesday 5th of April, 14:36 EET. It released a change that in some Windows clients caused a blue screen.

When this was reported to us we immediately started to investigate. A fix with update F-Secure Ultralight Core 2022-04-05_02 was release on same day at 20:18 EET.

This update should be downloaded and applied automatically, but in some rare cases manual work is required. In these cases following steps are needed:

1. Boot the system into safe mode
2. Rename fsulgk.sys file in the directory:
- Business Suite product: ...\F-Secure\\Ultralight\ulcore\1649156793
- Elements Endpoint Protection product: ...\F-Secure\PSB\Ultralight\ulcore\1649156793
3. Reboot the device normally and let the product update the components. New driver will be registered and enabled by the update.

Alternatively, removing the product in safe mode would help to avoid the blue screen. After re-installation the device would no longer face the blue screen with the latest Ultralight Core 2022-04-05_02 update.

If you need assistance, do not hesitate to contact WithSecure Support.
https://www.withsecure.com/gb-en/support

Products affected by this incident are: WithSecure and F-Secure Windows Endpoint Protection products
Posted Apr 06, 2022 - 15:26 EEST
This incident affected: F-Secure Elements Endpoint Protection (Endpoints (Clients & Servers)) and Business Suite (Endpoints (Clients & Servers)).