F-Secure services are currently unreachable
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Jan 21, 2023 - 11:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2023 - 11:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 21, 2023 - 10:37 UTC
Investigating
We have identified an issue with our services and have begun investigation.
Posted Jan 21, 2023 - 08:22 UTC
This incident affected: F-Secure Global Operator Services (Operator Portal), F-Secure Operator Services APAC (Avenue APAC, SENSE SDK APAC, ID Protection APAC), F-Secure Operator Services NA (Avenue NA, SENSE SDK NA, ID Protection NA), F-Secure Operator Services EU (Avenue EU, SENSE SDK EU, ID Protection EU), and F-Secure Home Products (F-Secure SAFE, F-Secure IDP).