PSB3 Portal Inaccessible
Incident Report for F-Secure services
Resolved
The issue has been resolved
Posted Jun 03, 2019 - 10:11 EEST
Update
We are continuing to monitor for any further issues.
Posted Jun 03, 2019 - 08:43 EEST
Monitoring
Currently PSB3 portal and SAFE portal are accessible again. The issue is solved.
Posted Jun 03, 2019 - 07:07 EEST
Investigating
We are investigating a service outage of PSB3 Portal.
Effects are customers unable to access to PSB3 Portal.

We'll update this incident as new information is discovered.
Posted Jun 03, 2019 - 05:04 EEST
This incident affected: Protection Service for Business (PSB) (Portal).