Delay in handling of elevations
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 15:36 EET
Investigating
We are experiencing a delay in our handling of elevations. If you have elevated a detection to us, please contact our support, we'll ensure your elevation is handled with priority.
You can find our phone numbers and opening ours here: https://www.f-secure.com/en/business/support-and-downloads
Posted Oct 29, 2020 - 16:16 EET
This incident affected: F-Secure Elements Endpoint Detection and Response (prev. RDR) (Portal).