My F-Secure account confirmation and password reset emails not delivered
Incident Report for F-Secure services
Resolved
We have fixed the My F-Secure account confirmation emails and password reset emails issue. Confirmation emails and password reset emails are going through now.
Posted Jan 13, 2023 - 17:43 UTC
Update
We have fixed the My F-Secure account confirmation emails and password reset emails issue. Confirmation emails and password reset emails are going through now.
Posted Jan 13, 2023 - 17:42 UTC
Investigating
We have identified that My F-Secure account confirmation emails and password reset emails are not going through to our customers. This does not impact the protection of devices.
 
We are investigating the issue with high priority.
Posted Jan 13, 2023 - 13:51 UTC
This incident affected: F-Secure Operator Services EU (Avenue EU), F-Secure Operator Services APAC (Avenue APAC), F-Secure Operator Services NA (Avenue NA), and F-Secure Home Products (F-Secure SAFE, F-Secure IDP).