security cloud ratings are currently not updated
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Dec 23, 2019 - 09:31 EET
Monitoring
We have recovered the service and continue monitoring the situation.
Posted Dec 20, 2019 - 17:20 EET
Identified
We have identified an issue where security cloud ratings are not updated.
This limits our ability to fix possible false positives quickly however protection of the end points is not compromised.
Posted Dec 20, 2019 - 10:50 EET
This incident affected: F-Secure Home Products (F-Secure SAFE), Protection Service for Business (PSB) (Endpoints (Clients & Servers)), and Business Suite (Endpoints (Clients & Servers)).