Unable to login to RDR and RDS Portal
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 10:16 EET
Update
We have identified that RDS Portal is also affected by this service outage/degradation.

We'll update this incident as new information is discovered.
Posted Oct 29, 2020 - 09:45 EET
Investigating
We are investigating a service outage/degradation of RDR Portal.
Logging on to RDR portal returns error "Rapid Detection & Response is on maintenance. Please try again later."

We'll update this incident as new information is discovered.
Posted Oct 29, 2020 - 08:28 EET
This incident affected: Rapid Detection and Response Service (RDS) (Portal) and F-Secure Elements Endpoint Detection and Response (prev. RDR) (Portal).