F-Secure Elements Mobile Protection for Android crashes on upgrade
Incident Report for F-Secure services
Resolved
A new version has been published in Google Play store that resolves the issue.
Posted Feb 09, 2022 - 09:54 EET
Investigating
We are investigating an issue where upgrading F-Secure Elements Mobile Protection for Android from version 18.4 to 18.5 results in a crash of the application.
To work around the issue, uninstall the F-Secure Elements Mobile Protection for Android app and install it again from the Google Play Store.
Posted Feb 04, 2022 - 14:04 EET