Windows Security products may stop updating or generate high traffic until rebooted
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 10:42 EET
Monitoring
We identified an issue affecting our Windows security products, in which some clients would stop updating after 23rd of October until the system is restarted or some clients would trigger unusually large traffic downloading all databases instead of only new updates.
A restart of the computer would recover the situation in all cases.

We have already deployed an automatic update to all our Consumer and Operator customers as well as customers of our F-Secure Protection Service for Business.
If you have one of these products, no action is needed.

For customers using our Business Suite products (Client Security 14.x or later, Server Security 14.x, Email and Server Security 14.x), We have a hotfix which you can deploy centrally. This hotfix restarts the FS Hoster service, recovering the clients.
The hotfix is available to download here: https://download.f-secure.com/corpro/cs/cs15.00/fscs1500-hf01-signed.jar

Our customers computers and servers remained protected throughout the incident. Your security is not compromised.

We have identified the underlying cause of the issue and have taken steps to prevent it from reoccurring.
Posted Oct 29, 2020 - 13:54 EET
This incident affected: F-Secure Operator Services EU (Avenue EU), F-Secure Home Products (F-Secure SAFE), F-Secure Operator Services NA (Avenue NA), F-Secure Operator Services APAC (Avenue APAC), Business Suite (Endpoints (Clients & Servers)), and F-Secure Elements Endpoint Protection (prev. PSB) (Endpoints (Clients & Servers)).