OSX: Safari may show blank screen after log in to My F-Secure portal for customers of our Operator partners using Single Sign On
Incident Report for F-Secure services
Resolved
The issue has been resolved. If you are running an older version of MacOS or Safari, please upgrade to version MacOS 10.15.3 and Safari 13.0.5.
Posted Feb 07, 2020 - 16:03 EET
Identified
Currently customers using OS X Catalina and Mojave with Safari 13.0.1 or later may be getting a blank page when logging in to the My F-secure portal.
A workaround is to use a different browser, until the issue is resolved.

Affected are customers of our operator partners that use Single Sign On.
Posted Jan 24, 2020 - 11:05 EET
This incident affected: F-Secure Operator Services APAC (Avenue APAC), F-Secure Operator Services NA (Avenue NA), and F-Secure Operator Services EU (Avenue EU).