PSB EMEA 1 Portal Access Issue
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 09:57 EET
Update
We continue monitoring the performance and availability.
Posted Oct 11, 2019 - 15:45 EEST
Monitoring
Currently PSB EMEA 1 portal is restored and users are able to login now.
Posted Oct 11, 2019 - 11:29 EEST
Investigating
We are investigating a service outage of PSB EMEA 1 Portal.
Effects are customers unable to access to PSB EMEA 1 Portal.

We'll update this incident as new information is discovered.
Posted Oct 11, 2019 - 09:08 EEST
This incident affected: Protection Service for Business (PSB) (Portal).