URL ratings are not updated
Incident Report for F-Secure services
Resolved
This incident has been resolved.
Posted Nov 11, 2019 - 14:41 EET
Update
We continue monitoring the situation over the weekend.
Posted Nov 08, 2019 - 16:23 EET
Monitoring
We have released a fix and are monitoring the situation. The deployment is automatic, no user action is required.
Posted Nov 07, 2019 - 16:59 EET
Investigating
We are investigating an issue where URL ratings in our security cloud are not properly updated.
This affects all endpoint products with Browsing Protection.

Visible effects are
- Malicious URLs might not be blocked
- URL false positive fixes might not be applied
- Content filtering category changes might not be applied

Endpoint protection is degraded, but other security measures are working correctly and provide protection.
Posted Nov 06, 2019 - 15:51 EET
This incident affected: Protection Service for Business (PSB) (Endpoints (Clients & Servers)) and Business Suite (Endpoints (Clients & Servers)).