Protection Service for Business - EMEA Portal - Service outage
Incident Report for F-Secure services
Resolved
The issue has been resolved. Protection Service for Business EMEA portal is operational again.
Posted Oct 08, 2019 - 16:05 EEST
Investigating
We are investigating an outage of our Protection Service for Business EMEA portal.
The portal may not be available, login may fail.
End point protection is not compromised, clients remain protected.
Posted Oct 08, 2019 - 15:20 EEST
This incident affected: Protection Service for Business (PSB) (Portal).